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Μετατροπή του project σε πακέτο.
Ενεργοποίηση παραγωγής εγγράφων 
roxygen:

Tools > Project Options > Build Tools
Οδηγός roxygen:

Help > Roxygen Quick Reference

File > New Project > 

New Directory > R Package

Κοινοποίηση έργου (project)

σε συνεργάτες Ενεργοί χρήστες

Επιλογή 

έκδοσης  
της R

Έναρξη νέας R
συνεδρίας(session)
στο τρέχων έργο

Κλείσιμο R 
συνεδρίας

JHT

Το RStudio αποθηκεύει το 
ιστορικό εκτελέσεων, τον χώρο 
εργασίας και τον κατάλογο 
εργασίας που σχετίζεται με ένα 
έργο. Επαναφορτώνεται κάθε 
φορά που ανοίγετε εκ νέου ένα 
έργο.

Όνομα έργου

View(<data>) ανοίγει ένα υπολογιστικό φύλλο ως 
προβολή του συνόλου δεδομένων

Ταξινόμηση τιμών
Φίλτρο γραμμών ανά 
τιμή ή εύρος τιμών

Αναζήτηση τιμής

Το παράθυρο προβολής(Viewer) εμφανίζει περιεχόμενο 
σε HTML, όπως εφαρμογές Shiny, RMarkdown

αναφορές και διαδραστικά γραφήματα

Διακοπή 
εφαρμογής Shiny

Δημοσίευση στο shinyapps.io, 
rpubs, RSConnect, …

Ανανέωση

Το RStudio ανοίγει τα βοηθητικά έγγραφα σε ένα ειδικό 
παράθυρο βοήθειας.

Αρχική σελίδα 
χρήσιμων συνδέσμων

Αναζήτηση στο έγγραφο 
της βοήθειας

Αναζήτηση

Στην καρτέλα packages υπάρχει μια λίστα με κάθε 
εγκατεστημένο πακέτο.

Επιλέξτε για να φορτώσετε 
πακέτο μέσω της library().
Αποεπιλέξτε για να αποσυνδέσετε 
ένα πακέτο μέσω της detach().

Απεγκατάσταση
πακέτου

Εγκατάσταση 
πακέτων

Ενημέρωση 
πακέτων

Δημιουργία 
αναπαραγωγίσιμου
πακέτου

Το RStudio ανοίγει τα γραφήματα σε 
ξεχωριστό παράθυρο.

Πλοήγηση
γραφημάτων

Άνοιγμα σε 
παράθυρο

Εξαγωγή 
γραφήματος

Διαγραφή
γραφήματος

Διαγραφή
όλων των 
γραφημάτων

Εγκατεστημένη 
έκδοση πακέτου

Εξετάστε τις 
μεταβλητές στο 
περιβάλλον εκτέλεσης

Άνοιγμα με debug(), browser(), ή ένα σημείο διακοπής(breakpoint). 
Το RStudio θα ανοίξει την λειτουργία εντοπισμού σφαλμάτων, όταν 
συναντήσει σημείο διακοπής κατά τη διάρκεια εκτέλεσης του κώδικα.

Άνοιγμα ανίχνευσης (traceback) για 
να εξετάσετε τις συναρτήσεις, οι 
οποίες εκτελέστηκαν πριν 
εμφανιστεί το σφάλμα.

Έναρξη λειτουργίας 
εντοπισμού σφαλμάτων

Κάντε κλικ δίπλα 
στον αριθμό 
γραμμής για να 
προσθέσετε / 
αφαιρέσετε ένα 
σημείο διακοπής.

Επιλογή συνάρτησης 
στην κατάσταση 
ανίχνευσης (traceback)
για αποσφαλμάτωση

Η επισημασμένη 
γραμμή δείχνει που 
έχει σταματήσει η 
εκτέλεση του κώδικα.

Εκτελέστε εντολές σε 
περιβάλλον όπου η 
εκτέλεση έχει τεθεί σε 
παύση

Πλοήγηση 
στον κώδικα
μια γραμμή 
κάθε φορά

Βήμα προς τα 
μέσα ή έξω από 
συναρτήσεις 
εκτέλεσης

Συνέχεια 
εκτέλεσης

Έξοδος από 
τη λειτουργία 
εντοπισμού 
σφαλμάτων

Άνοιγμα Shiny, R Markdown, 
knitr, Sweave, LaTeX, .Rd 
αρχείων κ.ά.

Ορθογραφικός 
έλεγχος Αρχείο 

απόδοσης

Μορφότυπος
εξόδου

Θέση 
εξόδου

Εισαγωγή 
κομματιού 
κώδικα (code 
chunk)

Μετάβαση σε 
προηγούμενο
κομμάτι κώδικα

Μετάβαση σε επόμενο 
κομμάτι κώδικα

Εκτέλεση 
επιλεγμένων 
γραμμών

Δημοσίευση σε 
εξυπηρετητή

Περίγραμμα 
κώδικα

Ορισμός παραμέτρων
knitr κομματιού

Εκτέλεση αυτού και όλων των 
προηγούμενων κομματιών κώδικα

Εκτέλεση τρέχων 
κομματιού κώδικα

Μετάβαση σε 
συγκεκριμένο 
κομμάτι κώδικα

Το RStudio αναγνωρίζει ότι αρχεία με όνομα app.R, 
server.R, ui.R, και global.R αφορούν  εφαρμογή shiny

Εκτέλεση 
εφαρμογής Επιλογή προβολής 

για την εφαρμογή

Δημοσίευση στο shinyapps.io 
ή σε εξυπηρετητή

Διαχείριση 
λογαριασμών 
δημοσίευσης

Πρόσβαση στον οδηγό χρήσης markdown:

Help > Markdown Quick Reference

Καταχωρημένα 
αρχεία

Δείτε τις 
αλλαγές

Υποβολή 
καταχωρημένων 
αρχείων

Κοινοποίηση/
Συγχώνευση 
στον διακομιστή

Προβολή 
ιστορικού

Τρέχων 
κλάδος

• Προστέθηκε

• Αφαιρέθηκε

• Τροποποιήθηκε

• Μετονομάστηκε

• Δεν εντοπίστηκε

Ενεργοποίηση: Tools > Project Options > Git/SVN

Άνοιγμα γραμμής εντολών
για να πληκτρολογήσετε 
εντολές

A

D

M

R

?

Εύρεση στο 
περιβάλλον

Συντακτική επισήμανση κειμένου 
βασιζόμενη στο τύπο αρχείου

Διαγνωστικά κώδικα που εμφανίζονται στο 
περιθώριο. Αφήστε το ποντίκι πάνω από το 
εικονίδιο για περισσότερες πληροφορίες.

Συμπλήρωση μιας συνάρτησης 
και των παραμέτρων της, με tab.

Βοηθητικά αποσπάσματα 
κώδικα (code snippets).

Άνοιγμα σε νέο 
παράθυρο

Αποθήκευση

Εύρεση και 
αντικατάσταση

Μεταγλώτισση
σημειωματάριου

Εκτέλεση 
επιλεγμένου κώδικα

Επανεκτέλεση
προηγούμενου 
κώδικα

Source with or 
without Echo

Show file 
outline

Μετάβαση σε συνάρτηση Αλλαγή τύπου σε αρχείο

Πλοήγηση 
καρτελών

Ένα παράθυρο περιήγησης αρχείων του καταλόγου εργασίας σας. 
Κάντε κλικ στο όνομα αρχείου ή καταλόγου για να το ανοίξετε.

Διαδρομή του εμφανιζόμενου καταλόγου

Ανέβασμα 
αρχείου

Δημιουργία 
φακέλου

Διαγραφή
αρχείου

Μετονομασία 
αρχείου

Αλλαγή 
καταλόγου 
(directory)

Προβολή αποθηκευμένων 
αντικειμένων ανά τύπο με 
σύντομη περιγραφή

Προβολή κώδικα 
συνάρτησηςΠροβολή

Φόρτωση 
χώρου 
εργασίας 
(workspace)

Αποθήκευση 
χώρου 
εργασίας

Οδηγός 
Εισαγωγής 
δεδομένων

Διαγραφή όλων των 
αποθηκευμένων 
αντικειμένων

Προβολή αντικειμένων 
ως λίστα ή πλέγμαΕπιλογή περιβάλλοντος για  προβολή

Ιστορικό 
προηγούμενων 
εκτελεσμένων 
εντολών

Προβολή .RPres
παρουσιάσεων
File > New  File > 

R Presentation

Κατάλογος εργασίας
(Working Directory)

Μεγιστοποίηση/
Ελαχιστοποίηση 
παραθύρων

Σύρετε για τα όρια 
του παραθύρου

JHT

Κέρσορας 
χρήστη

File > New Project

Πατήστε για να 
δείτε το ιστορικό 
εντολών.

Πολλαπλοί κέρσορες/επιλογή στήλης 
χρησιμοποιώντας Alt + mouse drag.

Έγγραφα και Εφαρμογές Υποστήριξη R

PROJECT SYSTEM

Κατάσταση Αποσφαλμάτωσης (Debug Mode) Σύστημα Ελέγχου Εκδόσεων
(Version Control) με Git ή SVN

Δημιουργία πακέτων

Μετάφραση: Κλεάνθης Κουπίδης •  koupidis@okfn.gr • @kleanthis_k10
Δρ. Χαράλαμπος Μπράτσας •  cbratsas@math.auth.gr • @Bratsas
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3 Πλοήγηση στον Κώδικα Windows /Linux Mac

Μετάβαση σε αρχείο/συνάρτηση Ctrl+. Ctrl+.

Σύμπτυξη επιλεγμένων Alt+L Cmd+Option+L

Αποσύμπτυξη επιλεγμένων Shift+Alt+L Cmd+Shift+Option+L

Σύμπτυξη όλων Alt+O Cmd+Option+O

Αποσύμπτυξη όλων Shift+Alt+O Cmd+Shift+Option+O

Μετάβαση στη γραμμή Shift+Alt+G Cmd+Shift+Option+G

Μετάβαση σε Shift+Alt+J Cmd+Shift+Option+J

Αλλαγή καρτέλας Ctrl+Shift+. Ctrl+Shift+.

Προηγούμενη καρτέλα Ctrl+F11 Ctrl+F11

Επόμενη καρτέλα Ctrl+F12 Ctrl+F12

Πρώτη καρτέλα Ctrl+Shift+F11 Ctrl+Shift+F11

Τελευταία καρτέλα Ctrl+Shift+F12 Ctrl+Shift+F12

Περιήγηση πίσω Ctrl+F9 Cmd+F9

Περιήγηση μπροστά Ctrl+F10 Cmd+F10

Μετάβαση σε ζεύγος αγκίστρων Ctrl+P Ctrl+P

Επιλογή μεταξύ ζεύγους αγκίστρων Ctrl+Shift+Alt+E Ctrl+Shift+Option+E

Εύρεση επιλεγμένου Ctrl+F3 Cmd+E

Εύρεση σε αρχεία Ctrl+Shift+F Cmd+Shift+F

Εύρεση επόμενου Win: F3, Linux: Ctrl+G Cmd+G

Εύρεση προηγούμενου
W: Shift+F3, L: 
Ctrl+Shift+G

Cmd+Shift+G

Μετακίνηση κατά λέξη Ctrl+ / Option+ /

Μετακίνηση στην αρχή/τέλος του εγγράφου Ctrl+ / Cmd+ /

Προβολή/Απόκρυψη προχείρου Ctrl+Shift+O Cmd+Shift+O

8 Έγγραφα και Εφαρμογές Windows/Linux Mac

Προβολή HTML (Markdown, etc.) Ctrl+Shift+K Cmd+Shift+K

Δημιουργία Εγγράφου (knitr) Ctrl+Shift+K Cmd+Shift+K

Μεταγλώττιση Σημειωματάριου Ctrl+Shift+K Cmd+Shift+K

Μεταγλώττιση PDF (TeX and Sweave) Ctrl+Shift+K Cmd+Shift+K

Εισαγωγή κομματιού κώδικα (Sweave and Knitr) Ctrl+Alt+I Cmd+Option+I

Εισαγωγή ενότητας κώδικα Ctrl+Shift+R Cmd+Shift+R

Επανεκτέλεση προηγούμενη ενότητα Ctrl+Shift+P Cmd+Shift+P

Εκτέλεση εγγράφου Ctrl+Alt+R Cmd+Option+R

Εκτέλεση από την αρχή έως την τρέχουσα γραμμή Ctrl+Alt+B Cmd+Option+B

Εκτέλεση της τρέχουσας ενότητας κώδικα Ctrl+Alt+T Cmd+Option+T

Εκτέλεση Προηγούμενου Sweave/Rmd code Ctrl+Alt+P Cmd+Option+P

Εκτέλεση τρέχοντος κομματιού κώδικα Ctrl+Alt+C Cmd+Option+C

Εκτέλεση επόμενου κομματιού κώδικα Ctrl+Alt+N Cmd+Option+N

Προεπισκόπηση pdf Ctrl+F8 Cmd+F8

Προηγούμενο Γράφημα Ctrl+Alt+F11 Cmd+Option+F11

Επόμενο Γράφημα Ctrl+Alt+F12 Cmd+Option+F12

Προβολή Συντομεύσεων Πληκτρολογίου Alt+Shift+K Option+Shift+K

7 Κατασκευή Πακέτων Windows/Linux Mac

Εγκατάσταση και φόρτωση Ctrl+Shift+B Cmd+Shift+B

Φόρτωση όλων (devtools) Ctrl+Shift+L Cmd+Shift+L

Δοκιμή (test) πακέτου (επιφάνεια εργασίας) Ctrl+Shift+T Cmd+Shift+T

Δοκιμή (test) πακέτου (Web) Ctrl+Alt+F7 Cmd+Opt+F7

Έλεγχος (check) πακέτου Ctrl+Shift+E Cmd+Shift+E

Αρχεία Τεκμηρίωσης Πακέτου Ctrl+Shift+D Cmd+Shift+D

6 Έλεγχος Εκδόσεων (VERSION CONTROL) Windows/Linux Mac

Προβολή αλλαγών Ctrl+Alt+D Ctrl+Option+D

Υποβολή αλλαγών Ctrl+Alt+M Ctrl+Option+M

Κύλιση προς τα πάνω κάτω στο παράθυρο αλλαγών Ctrl+ / Ctrl+ /

Καταχώρηση/Ακύρωση καταχώρησης (Git) Spacebar Spacebar

Καταχώρηση/Ακύρωση καταχώρησης και επόμενο Enter Enter

5 Αποσφαλμάτωση Κώδικα Windows/Linux Mac

Εισαγωγή/Αφαίρεση Σημείων Διακοπής (Breakpoint) Shift+F9 Shift+F9

Εκτέλεση Επόμενης Γραμμής F10 F10

Βήμα μέσα σε συνάρτηση Shift+F4 Shift+F4

Διακοπή Συνάρτησης/Βρόγχου Shift+F6 Shift+F6

Συνέχεια Shift+F5 Shift+F5

Διακοπή αποσφαλμάτωσης Shift+F8 Shift+F8

2 Εκτέλεση Κώδικα Windows/Linux Mac

Αναζήτηση ιστορικού εντολών Ctrl+ Cmd+

Πλοήγηση ιστορικού εντολών / /

Μετακίνηση στην αρχή της γραμμής Home Cmd+

Μετακίνηση στο τέλος της γραμμής End Cmd+ 

Αλλαγή καταλόγου εργασιών (working 
directory)

Ctrl+Shift+H Ctrl+Shift+H

Διακοπή Εντολής Esc Esc

Καθαρισμός κονσόλας Ctrl+L Ctrl+L

Έξοδος(επιφάνεια εργασίας) Ctrl+Q Cmd+Q

Επανεκκίνηση R συνεδρίας Ctrl+Shift+F10 Cmd+Shift+F10

Εκτέλεση γραμμής/επιλογής Ctrl+Enter Cmd+Enter

Εκτέλεση (διατήρηση κέρσορα) Alt+Enter Option+Enter

Εκτέλεση έως το τέλος του κώδικα Ctrl+Alt+E Cmd+Option+E

Εκτέλεση συνάρτησης ορισμού Ctrl+Alt+F Cmd+Option+F

Δημιουργία πηγαίου αρχείου Ctrl+Alt+G Cmd+Option+G

Δημιουργία πηγαίου αρχείου (αφορά το 
ενεργό αρχείο)

Ctrl+Shift+S Cmd+Shift+S

Δημιουργία πηγαίου αρχείου και εκτέλεση Ctrl+Shift+Enter Cmd+Shift+Enter

1 Διάταξη Windows/Linux Mac
Μετακίνηση κέρσορα στην παράθυρο 
επεξεργασίας κώδικα

Ctrl+1 Ctrl+1

Μετακίνηση κέρσορα στην κονσόλα Ctrl+2 Ctrl+2

Προβολή βοήθειας Ctrl+3 Ctrl+3

Προβολή ιστορικού Ctrl+4 Ctrl+4

Προβολή αρχείων Ctrl+5 Ctrl+5

Προβολή γραφημάτων Ctrl+6 Ctrl+6

Προβολή πακέτων Ctrl+7 Ctrl+7

Προβολή περιβάλλοντος Ctrl+8 Ctrl+8

Προβολή Git/SVN Ctrl+9 Ctrl+9

Προβολή Build Ctrl+0 Ctrl+0
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Ο RSP επεκτείνει τον ανοικτού κώδικα εξυπηρετητή με 
εμπορική άδεια χρήσης, υποστήριξη και πολλά 
περισσότερα:

• Άνοιγμα και εκτέλεση πολλαπλών R συνεδριών ταυτόχρονα

• Συντονίστε τους πόρους σας για να βελτιώσετε την απόδοση

• Κοινή επεξεργασία project μαζί με άλλους

• Δείτε τι κάνετε εσείς και οι άλλοι στον διακομιστή

• Εύκολη μετάβαση από μία έκδοση της R σε άλλη

• Ενσωματώστε πρακτικές ελέγχου ταυτότητας, εξουσιοδότησης και ελέγχου

Κατεβάστε και δοκιμάστε δωρεάν για 45 μέρες:

www.rstudio.com/products/rstudio-server-pro/

Γιατί RSTUDIO SERVER PRO?4 Κώδικας Windows /Linux Mac

Εισαγωγή χαρακτήρα tab Tab or Ctrl+Space Tab or Cmd+Space

Πλοήγηση / /

Αποδοχή/Αλλαγή γραμμής Enter, Tab, ή Enter, Tab, ή

Άκυρο Esc Esc

Αναίρεση Ctrl+Z Cmd+Z

Ακύρωση Αναίρεσης Ctrl+Shift+Z Cmd+Shift+Z

Αποκοπή Ctrl+X Cmd+X

Αντιγραφή Ctrl+C Cmd+C

Επικόλληση Ctrl+V Cmd+V

Επιλογή Όλων Ctrl+A Cmd+A

Διαγραφή Γραμμής Ctrl+D Cmd+D

Επιλογή Shift+[Βέλος] Shift+[Βέλος]

Επιλογή Λέξης Ctrl+Shift+ / Option+Shift+ /

Επέκταση επιλογής έως την αρχή της γραμμής Alt+Shift+ Cmd+Shift+

Επέκταση επιλογής έως το τέλος της γραμμής Alt+Shift+ Cmd+Shift+

Επέκταση επιλογής κατά μία σελίδα πάνω/κάτω Shift+PageUp/Down Shift+PageUp/Down

Επέκταση επιλογής έως την αρχή/τέλος του εγγράφου Shift+Alt+ / Cmd+Shift+ /

Διαγραφή λέξης αριστερά Ctrl+Backspace Ctrl+Opt+Backspace

Διαγραφή λέξης δεξιά Option+Delete

Διαγραφή έως το τέλος της γραμμής Ctrl+K

Διαγραφή έως την αρχή της γραμμής Option+Backspace

Αύξηση εσοχής γραμμής Tab (at start of line) Tab (at start of line)

Μείωση εσοχής γραμμής Shift+Tab Shift+Tab

Αντιγραφή γραμμής έως τη θέση του κέρσορα Ctrl+U Ctrl+U

Αντιγραφή από τη θέση του κέρσορα έως το τέλος της γραμμής Ctrl+K Ctrl+K

Επικόλληση Ctrl+Y Ctrl+Y

Εισαγωγή <- Alt+- Option+-

Εισαγωγή %>% Ctrl+Shift+M Cmd+Shift+M

Προβολή Βοήθειας για Συνάρτηση F1 F1

Προβολή πηγαίου κώδικα συνάρτησης F2 F2

Νέο Έγγραφο Ctrl+Shift+N Cmd+Shift+N

Νέα Καρτέλα (Chrome) Ctrl+Alt+Shift+N Cmd+Shift+Opt+N

Άνοιγμα Ctrl+O Cmd+O

Αποθήκευση Ctrl+S Cmd+S

Κλείσιμο Ctrl+W Cmd+W

Κλείσιμο καρτέλας (Chrome) Ctrl+Alt+W Cmd+Option+W

Κλείσιμο όλων Ctrl+Shift+W Cmd+Shift+W

Απόσπαση συνάρτησης Ctrl+Alt+X Cmd+Option+X

Απόσπαση μεταβλητής Ctrl+Alt+V Cmd+Option+V

Προσαρμογή εσοχής στη γραμμή Ctrl+I Cmd+I

Προσθήκη/Αφαίρεση σχολίου Ctrl+Shift+C Cmd+Shift+C

Αναδιαμόρφωση σχολίου Ctrl+Shift+/ Cmd+Shift+/

Επαναδιαμόρφωση επιλεγμένου κειμένου Ctrl+Shift+A Cmd+Shift+A

Επιλογή μεταξύ ζεύγους αγκίστρων Ctrl+Shift+E Ctrl+Shift+E

Εμφάνιση διαγνωστικών Ctrl+Shift+Alt+P Cmd+Shift+Opt+P

Μετατροπή γραμμάτων Ctrl+T

Μετακίνηση γραμμής πάνω/κάτω Alt+ / Option+ /

Αντιγραφή άνω/κάτω γραμμής Shift+Alt+ / Cmd+Option+ /

Επέκταση κέρσορα πάνω Ctrl+Alt+Up Ctrl+Option+Up

Επέκταση κέρσορα κάτω Ctrl+Alt+Down Ctrl+Option+Down

Μετακίνηση επέκτασης κέρσορα πάνω Ctrl+Alt+Shift+Up Ctrl+Option+Shift+Up

Μετακίνηση επέκτασης κέρσορα κάτω Ctrl+Alt+Shift+Down Ctrl+Opt+Shift+Down

Εύρεση Ctrl+F Cmd+F

Εύρεση επιλεγμένου Ctrl+F3 Cmd+E

Αντικατάσταση Ctrl+Shift+J Cmd+Shift+J
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